Problem
When you
try to install Microsoft Internet Information Services (IIS) on a computer that
is running Microsoft Windows XP Professional with Service Pack 2 (SP2), you may
receive one of the following error messages:
Copy error:
• Setup
cannot copy the file staxmem.dll. Please insert the "Windows XP Professional
Service Pack 2 CD".
• Setup could not copy one or more files. The
specific error code is 0x4b8
However, when you put the Windows XP
Professional SP2 CD in your CD drive, Setup cannot find the Staxmem.dll
file.
Cause
This
issue may occur when one of the following conditions is true:
• The
Secedit.sdb database file is corrupted.
• The Windows Components Wizard
(Sysocmgr.exe) must install files in such a way that both the original Windows
XP Professional CD and the Windows XP Professional SP2 CD must be available.
Solution
To
resolve this issue, first run the Esentutl.exe tool to examine the integrity of
the Secedit.sdb database. To do this, follow these steps:
1. Click
Start, click Run, type cmd, and then click OK.
2. At the command prompt,
type the following command, and then press ENTER:
esentutl /g
Drive:\WinDir\security\database\secedit.sdb
Note: In this
command, Drive is the hard disk drive where Windows XP Professional is
installed, and WinDir is the folder where Windows XP Professional is installed.
After the Esentutl.exe tool finishes, use one of the following methods
to resolve the issue, depending on the message that the Esentutl.exe tool
returns:
• If the Esentutl.exe tool returns the following message, use
Method 1 to resolve the issue:
This operation may find that this
database is corrupt
• If the Esentutl.exe tool returns information that
is similar to the following message, use Method 2 to resolve the issue:
Microsoft(R) Windows(R) Database Utilities
Version
5.2
Copyright (C) Microsoft Corporation. All Rights Reserved.
Initiating INTEGRITY mode...
Database:
L:\WINDOWS\security\database\secedit.sdb
Temp. Database:
TEMPINTEG2680.EDB
Checking database integrity.
Scanning Status (% complete)
0 10 20 30 40 50 60 70 80 90
100
|---|---|---|---|---|---|---|---|---|---|
...................................................
Integrity check successful.
Operation completed successfully in 0.841 seconds.
Note: When you run the Esentutl.exe tool, your computer is
returned to the original installation state where the Local Security Policy is
not defined. You may have to start your computer in Safe Mode to rename files or
to move files. To start your computer in Safe Mode, press the F8 key while
Windows XP Professional is starting, type 1 to choose Safe Mode from the startup
options, and then press ENTER.
Method 1:
Repair or re-create the local Group Policy file
To repair the local Group Policy file, follow
these steps:
1. Click Start, click Run, type cmd, and then click
OK.
2. At the command prompt, type the following command, and then press
ENTER:
esentutl /p
Drive:\WinDir\security\database\secedit.sdb
Note: In this
command, Drive is the hard disk drive where Windows XP Professional is
installed, and WinDir is the folder where Windows XP Professional is
installed.
3. Try to install IIS. If you cannot install IIS, complete
the following steps to re-create the local Group Policy file.
To
re-create the local Group Policy file, follow these steps: 1. Click Start, click
Run, type explorer, and then click OK.
2. Locate and then open the
Drive:\WinDir folder.
3. Create a new folder in the Drive:\WinDir
folder, and then name the new folder OldSecurity. To do this, follow these
steps:
a. Double-click the WinDir folder.
b. On the
File menu, point to New, and then click Folder.
c. Type
OldSecurity, and then press ENTER.
4. Move all the files that have a
.log file name extension from the Drive:\WinDir\Security folder to the
Drive:\WinDir\OldSecurity folder. To do this, follow these
steps:
a. Double-click the Security folder, and then hold down the
CTRL key while you click each file that has a .log file name
extension.
b. On the Edit menu, click Cut.
c. Locate
and then click the OldSecurity folder.
d. On the Edit menu, click
Paste.
5. Find the Secedit.sdb file in the
Drive:\WinDir\Security\Database folder, and then rename the Secedit.sdb file to
Secedit.old. To do this, follow these steps:
a. Right-click
Secedit.sdb, and then click Rename.
b. Type Secedit.old, and then
press ENTER.
6. Click Start, click Run, type mmc, and then click
OK.
7. Add the Security Configuration and Analysis snap-in. To do this,
follow these steps.
a. Click File, click Add/Remove Snap-in, click
Security Configuration and Analysis in the Available Standalone Snap-ins list,
and then click Add.
b. In the Add Standalone Snap-in dialog box,
click Close.
c. In the Add/Remove Snap-in dialog box, click
OK.
8. Right-click Security and Configuration Analysis, and then click
Open Database.
9. Locate the Drive:\WinDir\Security\Database folder. In
the File name box, type Secedit.sdb, and then click Open.
Note: If you receive a message that states that access is
denied, you can ignore the message.
10. Right-click Security and
Configuration Analysis, click Import Template, type setup security.inf, and then
click Open.
11. If you are prompted to restart your computer, restart
your computer.
12. Try to install IIS. If you cannot install IIS,
complete the steps in Method 2.
Method 2: Integrate the Windows XP
Professional SP2 installation files into the original version of the Windows XP
Professional installation files
To integrate the Windows
XP Professional SP2 installation files into the original version of the Windows
XP Professional installation files, follow these steps:
1. Create a new
folder that does not contain any files. To do this, follow these
steps:
a. Click Start, click Run, type cmd, and then click
OK.
b. At the command prompt, type cd \, and then press
ENTER.
c. At the command prompt, type md winxp, and then press
ENTER.
d. At the command prompt, type cd winxp, and then press
ENTER.
e. At the command prompt, type md i386, and then press
ENTER.
2. Put the original version of the Windows XP Professional CD
into your CD drive.
3. At the command prompt, type the following
command, and then press ENTER:
xcopy /E /I /V CD_Drive:\i386\*.* /s
Drive:\winxp\i386
Note: In this command, CD_Drive is the CD
drive where the original version of the Windows XP Professional CD is
located.
4. Remove the Windows XP Professional CD from the CD drive, and
then put the Windows XP Professional SP2 CD in the CD drive.
5. At the
command prompt, type the following command, and then press
ENTER:
CD_Drive:
Note: In this command, CD_Drive
is the CD drive where the Windows XP Professional SP2 CD is located.
6.
At the command prompt, type the following command, and then press
ENTER:
xpsp2 /integrate:Drive:\winxp
7. Install
IIS.
8. When you are prompted to locate the Windows XP Professional
installation files, type Drive:\winxp, and then press ENTER.
Article ID: 48, Created On: 10/14/2011, Modified: 10/14/2011